
 

 
Page 1 of 11 

18 September 2011 

  
  

Prior to connectivity with TLETS, agencies must become a TLETS member and undergo a security audit.  For 
information on the membership process, contact the TLETS Trainers at (512) 424-2419 or 
tlets@txdps.state.tx.us.  For information on the security audit, visit http://www.txdps.state.tx.us/securityreview to 
obtain policy information.  Specific questions and/or clarification requests should be directed to the DPS CJIS 
Security Office via email:  securitycommittee@txdps.state.tx.us.  All other questions may be directed to the TLETS 
Order Center at (512) 424-2256 or tlets_order_center@txdps.state.tx.us. 
 

EQUIPMENT and SOFTWARE REQUIREMENTS for TCP/IP 
 
Satellite 
Satellite installation requires the member agency to install a voice-grade telephone line to be used solely for the 
satellite’s Automatic Dial Backup modem. 
 
Workstation Specifications 
 
TxDPS has procured a Java Application, often called Omnixx but is frequently referred to as “workstation 
software”.  This software provides “direct connect” TLETS devices (or devices that are not behind an interface 
system).  This application is provided at no cost to TLETS member agencies.  DPS recommends, but does not 
require, all agencies to have at least one version of Omnixx installed at their location so that system 
modifications can be obtained as soon as they are released.  Recommended computer specifications are below.   
 

o CPU/Type/Speed:  2 GHz  
o Memory:  512 MB  
o Display Resolution:  1024 x 768  
o Disk Space Available:  300 MB  
o Operating System:  Windows XP SP3 or 2000 SP4  
o Interface:  TCP/IP Network Interface Card (NIC)  
o Java:  Version 1.5_121 

 
The software will operate on systems having the below minimum specifications, however the end user may 
experience slower performance: 
 

o CPU Type/Speed Pentium 600mhz and above 
o Memory 256 MB 
o Display Resolution 1024 x 768 
o Disk Space 50 MB 
o Operating System:  Windows XP SP3 or 2000 SP4  
o Java:  Version 1.5_121 

 
The specifications for the devices are for those offices running only Omnixx on the workstation.  If other 
applications are running simultaneously, TxDPS recommends more memory and CPU speed.  TxDPS is aware 
that computer systems currently available for purchase are delivered with Windows 7. There is no reason to 
believe that the system will not operate sufficiently on that platform, however, our vendor has not approved our 
current version of the software for operating on Windows Vista or Windows 7. Additionally, TxDPS personnel 

                                                 
1 Higher versions of Java may be installed on the equipment, but Java 1.5_12 must also reside on the machine.   
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do not have experience with these platforms, so assistance with issues in those operating environments is 
currently not available. 
 
The software will be installed from a CD which will be mailed to the agency following the initial contact call.  
TxDPS has detailed installation instructions which must be followed precisely.  The agency will be required to 
install the software on each computer that will use the Omnixx “workstation”.   
 
Printers 
 
Printing from within the Workstation application will be accomplished using a Windows defined printer.   
Printing can be accomplished in a variety of ways: 
 

• The Agency may request a direct connect printer.  The printer will be assigned a mnemonic and an IP 
address in the range of IPs assigned to the agency.  An agency requiring a TLETS printer for broadcast 
messages only could use this methodology. 
 

• The operator may redirect all messages received to a printer. This is accomplished by ensuring that 
“Auto Print” is selected under the Omnixx Force menu item “Options.”  In this mode, the printer is not 
assigned a mnemonic.  Omnixx will print all sent and received messages.   
 

• From the Omnixx Message window, the operator may select individual messages or groups of messages 
sent or received for printing. In this mode, the printer is not assigned a mnemonic. Messages are directed 
to the workstation and the TLETS operator is in control of what is and is not printed.  
 

• The operator may set the workstation software for unattended printing. Setting the workstation to this 
mode will log the operator out of the workstation and will log the printer onto the message switch. The 
workstation would remain powered-up and logged-in and the printer would need to be available and 
online.  An agency requiring a TLETS printer for broadcast messages only could use this methodology. 
This would require the existence of a PC having a windows printer attached; the PC could not be used 
for access to TLETS. 

Connectivity 
 
Most TLETS agencies connect to the DPS network over Satellite using a TxDPS-supplied transceiver called the 
HN7700.  The HN7700 can be thought of as a border router accomplishing interconnectivity with the DPS 
network in our descriptions for connectivity below.  DPS provides terrestrial connectivity to those agencies 
whose volumes exceed the numbers of transactions that can be supported over the Satellite System.   
 
Satellite Connected Agencies 
 
For Satellite-connected TLETS agencies, the HN7700 has an Ethernet port that provides the physical 
connection between the agency and the TLETS network.  Agencies having more than one device 
interconnecting with TLETS must design their network to exchange data with TLETS, ultimately achieving 
connectivity to a single Ethernet port on the TxDPS supplied HN7700.  This document should provide most of 
the information necessary to make that connection.  Configuration of equipment necessary to connect with 
TLETS will vary widely depending on the components that connect to TLETS and the complexity of the 
network establishing connectivity with TLETS when more than one device is involved. Agencies having 
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multiple devices connected into TLETS are responsible for configuring any network equipment for connectivity 
to the TLETS system.   
 
Regardless of the configuration at the Satellite connected agency, TxDPS assigns the local agency a range of IP 
addresses (a subnet) and each device at the local agency will be assigned a static IP address.  This information is 
relayed to the agency on the Terminal Connection Report (TCR).  The TCR is the replacement for the TDA 
sheet that TxDPS has provided to the agency in the past.  The heading of the TCR provides the Agency with an 
address labeled “Gateway” as well as the “Subnet mask”.  The gateway address combined with the subnet mask 
will identify the subnet (range of IP addresses) that can be used behind the HN7700.  Note that the “Gateway” 
address is the IP address that TxDPS has assigned to the HN7700 and is available for use by the local agency.   
 
Physical Connectivity is achieved by connecting agency computing equipment to the LAN 1 Ethernet port on 
the back of the HN7700.   
 
Scenario 1:  (Single Device).  The simplest scenario involves a single device connecting directly to TLETS and 
does not involve connectivity with any other network.  For this type of setup, the device is configured using the 
TxDPS supplied TCP/IP address and gateway information located on the TCR.  One end of a standard CAT5 
Ethernet cable will be inserted into the network interface card on the computer and the other end of the CAT5 
Ethernet cable will be placed into the HN7700.  Refer to the section entitled Workstation Setup for instructions 
on setting up the device which will connect to TLETS.  The agency must establish procedures to update their 
workstation with the latest security updates for the software running on this equipment, since this scenario does 
not necessarily provide for connectivity to any other network, including the Internet.   
 

 
Figure 1 Single Device Connectivity 

 
 
Scenario 2:  (Ethernet Switch Only).  This scenario describes a simple network that exchanges data with 
TLETS but does not interconnect with any other networks including the Public Internet.  For this type of setup, 
the local agency will provide an Ethernet switch with enough ports and cabling to connect all their devices to 
the HN7700.  The agency creates a physical connection between each device and the switch and one connection 
between the HN7700 and the switch using standard CAT5 Ethernet cables.   Follow the instructions found in 
the section entitled Workstation Setup for each individual workstation that will exchange data with TLETS.   
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Ethernet Switch
HN7700

 
Figure 2 Simple Network 

 
 
Scenario 3:  (Network).  This approach is taken when the local agency has an established network and/or the 
agency would like for their TLETS devices to connect to the Public Internet.  More complex networks will 
require configuration of network appliances, including routers, firewalls and possibly DNS servers.  Route 
statements, firewall rule sets, Network Address Translation (NAT) and any other configurations are the 
responsibility of the local agency and/or their vendor.  TxDPS will provide an address to the agency, usually the 
next subsequent address to the TxDPS Gateway, for assignment to a network device inside the local agency 
network.  The local agency would then have this “skipped” address available to them as an “inside” address 
they can use for configuring their network equipment to route properly.  The “skipped” address is listed as the 
“Agency Network IP” on the TCR.   
 

 
Figure 3 Complex Network 
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Two common ways that local agencies approach Connectivity when they have a complex network:   
 

1. Network Address Translation (NAT):  The agency would have a router capable of being configured for 
network address translation.  Many routers support NAT but not all routers are capable of setting up a 
preferred desired address space.  When using NAT properly, the TxDPS supplied addressing is 
converted by the router to the agency’s internal addressing scheme.  Although this approach is preferred, 
configuration of NAT is router-specific so TxDPS cannot assist the local agency with configuring their 
router for NAT.  Local agency personnel and/or their vendor should become familiar with this approach 
in preparation for connectivity.  Many resources are available on the Internet.   

 
2. Dual NIC cards or a single NIC card configured with two TCP/IP addresses.  Each device on the local 

agency’s network would be configured with two TCP/IP addresses.  One of the addresses would be the 
TxDPS TCP/IP address and the other address would either be a static address or a DHCP address 
assigned by the local agency and used within the agency’s LAN.  When an agency chooses this scenario, 
the following route statements with the appropriate substitutions are required to finalize the 
configuration:   

 
route -p add 170.193.46.67 mask 255.255.255.255 <txdps gateway> 
route -p add 170.193.47.9 mask 255.255.255.255 <txdps gateway> 
 

Terrestrial Connectivity 
 
For those agencies on terrestrial circuit, DPS will provide FRATM connectivity that will meet the bandwidth 
demands of the local agency.  The local agency is responsible for procurement and configuration of their border 
router.  DPS will work with the Terrestrial connected agencies to find an IP range that will work for them.  The 
Terrestrial Connected agencies will be similar to the Satellite connected Agencies but will not be required to use 
static IP addresses on the Omnixx client(s).  The router must have an available T1-WIC that supports CISCO 
Advanced IP Services.  One router specification that will work can be seen in Figure 4 Router Specification 
below:   
 
 
 
 
 
 
 
 
 
 
 

 

 
CISCO 2821 Bundle w/AIM-VPN/SSL-2, Adv. IP Serv 
64F/256D Power Cord,110V  
Updated 1-Port T1/Fractional T1 DSU/CSU WAN Interface Card  
Cisco 2800 ADVANCED IP SERVICES  
Cisco 2821/51 AC power supply  
Device manager for routers  
Feature License IOS SSL VPN Up To 10 Users (Incremental)  
256MB DDR DRAM Memory factory default for the Cisco 2800  
64MB CF default for Cisco 2800 Series  
DES/3DES/AES/SSL VPN Encryption/Compression  
ONSITE 24X7X4 2821  
Security Bundle,AIM-VPN-EPII-PLUS,Adv. IP 

 Figure 4 Router Specification 
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 Other Important Configuration Information:   
 
Name 
Resolution   

If the agency has a DNS server, an entry should be made to resolve the name DPSTLETS to the 
address 170.193.46.67.  If the agency does not have DNS, or the DNS server at the local agency 
requires an extension such as .COM, .ORG, etc, then the agency will need to modify the hosts 
file on each workstation and/or interface server as described in the section entitled Workstation 
Setup.   

Firewall 
Ports 

Access to the TLETS system on the TxDPS network requires the following ports be opened on 
any intervening firewalls:   
 

Address Port Description 
170.193.47.9 6600 Workstation software to message switch 
170.193.46.67 80 Login page (encrypted using AES) 
170.193.47.9 6800   TLETS interface systems (CAD, RMS or MDT) 

 
Access to Omnixx Trainer/Omnixx Console through the Internet will use ports 80 and 443 on 
 

http://tlets.txdps.state.tx.us/omnixx/desktop 
 

Permissions 
for Omnixx 
(the TxDPS 
supplied 
user 
interface) 

Windows Administrator privileges are required to install the software provided by TxDPS on 
CD.  After the initial install, all operators will need full control over the following directories 
on their system while using the TxDPS supplied Omnixx workstation software (the directories 
will be created at install time) or when accessing the TLETS Omnixx Training system available 
on the Internet.   
 

TLETS (C:\TLETS) 
Java (C:\Program Files\java\)  
Java Web Start (C:\Program Files\Java Web Start\)2  
 

The single most overlooked item is the need to provide operators FULL CONTROL over 
these directories and all subdirectories beneath those directories. 

 

                                                 
2 this directory does not always exist 
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Interface 
systems 
(CAD, RMS 
and Mobile 
Systems that 
Interface 
with 
TLETS) 
 

If a single physical computer will support multiple types of systems (CAD, RMS, MDT and/or 
other types of Mobile devices), and each of the systems will support formats requiring different 
permissions, the system must be able to transmit messages from each system using a unique 
DAC or XDAC.  In other words, two mnemonics would be associated with a single server.  The 
mobile system could then be configured to disallow Criminal History Record Information 
(CHRI) data.   
 
Interface systems are required to submit the unique TxDPS-issued UserID of the operator 
submitting transactions in the stream of data.  If the agency wishes to use local user IDs in lieu 
of the TxDPS issued userID, it is permissible to map the Local UserID to the TxDPS-issued 
UserID as long as the submitted UserID is the actual operator of the device.  TLETS validates 
the User Certifications to insure that the operator has appropriate authority in the system.  This 
covers the case where the local system is set up with UserIDs other than those issued by TxDPS 
and the local agency wants to continue to use those UserIDs and not the TxDPS user IDs.  To 
repeat, the interface will need to be capable of translating the “local” user ID to the TxDPS 
issued user ID.  This would be most easily accomplished by adding a table for the conversion so 
that as personnel turnover occurs, the table can be easily maintained by the local agency. 
 
TXDPS has established a test process for TLETS subscribers who implement interface systems. 
Agencies may use an additional IP address within their assigned subnet, and DPS will assign 
that device a test device name for testing.  This allows the participant to use the DPS network to 
communicate with the TLETS test system and exchange information with NCIC, Nlets, MVD, 
TCIC, Driver License, and CCH through the TLETS Test system. More information on 
interface Agency Testing can be found on the TLETS website under the link “TLETS Re-
Engineering” (instructions for accessing this website are below).   
 
The appropriate codebook (production and/or test) will be supplied to interface agencies for 
application layer AES encryption.   

 
Additional Information: 
 

Other helpful information can be found on the TLETS Re-Engineering link at the following website: 
 
http://www.txdps.state.tx.us/director_staff/information_management/tlets/tletsindex.htm 
The username is tlets and the case sensitive password is DPSTCIC7# 
 
It is highly recommended that the following documents, located on this website, be printed prior to 
beginning the installation of the software.    
 

“Workstation CD Install” 
“Omnixx Force Training Manual”  
“Omnixx Force Shortcut Keys”  
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Workstation Setup 
 

Important Notes:   
o There are several ways to perform many of these activities.  
o The person performing these activities MUST have administrative privileges in the machine.   
o These instructions cover the case where the agency is using the TxDPS assigned IP address(es) 

(Scenario 1 and Scenario 2).     
 

1. Establish Physical Connectivity.  See section Entitled “Connectivity” on Page 2 of this guide.   
 

2. Establish the TxDPS assigned TCP/IP address.   
a. Open the Control Panel.  Click on Start > Settings > Control Panel 
b. Double-click on the icon labeled “Network Connections” 
c. Select the entry related to the Ethernet card to be used to connect to TLETS.  If there is only one 

entry, select that entry.  Right mouse click.   
d. From the pop-up window, select “Properties” to display the following screen:   

 

 
 

 
 

e. Highlight “Internet Protocol (TCP/IP)” in the scrolling window, (you may have to use the scroll bar 
to find it), then click on the button labeled “Properties”.     
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f. A new window will open to allow the agency to configure the pertinent information.  If the new 
window contains values in the IP address, subnet mask, and/or default gateway, stop here and 
consult with a person familiar with your internal computer systems before proceeding. 

 

 
 
 

g. If the fields are “grayed out”, click the radio button “Use the following IP Address:” to enable the 
necessary fields. 

h. Referring to the “TLETS Terminal Connection Report” (TCR)  
i. The IP Address will be found under the heading “Address” on the line where the “Term Type” 

is “OMNX”.   
ii. The Subnet mask is at the top of the page under “TCP/IP Configs”.   

iii. Default gateway is the value associated to value labeled “TxDPS Gateway” at the top of the 
page under “TCP/IP Configs”.   

iv. Insert these values into the fields shown.  Be careful that the periods are identical to those shown 
on the TCR.   
 

2. Address resolution:  If the agency has a DNS server that has been configured according to the “Name 
Resolution” Instructions as described on Page 6, skip this section.  If no DNS server is available for address 
resolution, the agency will need to update the Windows hosts file on the workstation.  The operating system 
requires that the layout of the hosts file be precise, therefore it is very important that the agency not corrupt 
this file.    

a. Open Windows Explorer.  (One way to do this is to right mouse click on the start button and then 
select Explore from the pop-up window.) 

b. Navigate to C:\WINDOWS\system32\drivers\etc.     
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c. It is a good idea to make a backup copy of the hosts file before making any changes.   
d. Open the hosts file with notepad. 
e. Insert the following line onto a line by itself starting in the first column of a blank line, this will 

typically NOT be the first entry in the hosts file.   
 

170.193.46.67   dpstlets    # TLETS Web Server 
 

f. Save the file.  By clicking File > Save.   
 

3. Verify Connectivity:  The local agency should successfully ping the gateway. 
a. Click on Start > Run. 
b. Type cmd in the field and click on OK.   

 

 
 

c. This will open up a DOS command prompt. 
d. Type ping <gateway address>, substituting <gateway address> with the “Gateway” value from the 

TCR.  Press <enter>. 
e. The system should send 4 “ping” messages and receive 4 replies.  If there are no replies, the agency 

should validate steps 1-3 before proceeding.   
f. The local agency should try to ping the TxDPS webserver from the DOS command prompt. 
g. Type ping dpstlets at the DOS command prompt.   
h. Press <enter>. 
i. The workstation should send 4 “ping” messages and receive 4 replies.  If there are no replies, the 

agency should validate steps 1-3 before proceeding.   
j. The local agency should try to ping the TxDPS message broker from the DOS command prompt. 
k. Type ping 170.193.47.9 at the DOS command prompt.   
l. Press <enter>. 
m. The workstation should send 4 “ping” messages and receive 4 replies.  If there are no replies, the 

agency should validate steps 1-3 before proceeding. 
n. To close the DOS command prompt, type exit. 

 
4. If the agency has intervening firewalls in place, the following ports must be opened.  Consult with your 

technical staff regarding firewall configurations.   
 
i. 170.193.47.9:6600 

ii. 170.193.46.67:80 
 

5. The Agency should follow the steps identified in the CD install instructions document.   
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6. Users will need the following information to log into Omnixx: 
a. UserID as provided by the TLETS Order Center 
b. The initial password will be the same as the UserID (uppercase, case sensitive) 
c. Type in the appropriate mnemonic for the workstation 
d. Click Log In – Note:  The operator will be required to change the password at the first logon, but do not 

change the password on this screen 
e. Passwords must be comprised of one or more numbers, letters and symbols, are a minimum of 8 

characters long and a maximum of 15 characters long.   
f. Upon successful log on, the operator will be presented with the Certification Status page.  Operators 

should review the information presented and ensure they do not let their TLETS and TCIC certifications 
expire, otherwise they will lose access to the TLETS and/or TCIC transactions.  The Operator should 
Click Close on this screen.   

g. The Omnixx Desktop will then display.  The operator should click the Force icon to open up the TLETS 
browser application.  A manual is on the CD and/or the TLETS website.   

 
7. Printing is performed using a Windows defined printer.   

a. Set up a printer by selecting File > Print setup from the main Omnixx Force menu.  
b. Select Windows Printer (Graphic Mode)  
c. Select a printer from the list that has been defined to windows. Note: Line printer (Text Mode) is used 

for a printer connected to the LPT port of the computer.  
d. Some customers are dissatisfied with the default printing. In this case have technical personnel: 

1)“dummy up the driver”, e.g. try using an older driver for your printer or 2) create a shared printer in 
Windows for a USB connected printer and point the line printer to \\<computer ip address>\<share 
name> from the Omnixx Force Print Setup function. These actions sometimes change the default text to 
something more appealing.  

e. It is not possible to remove the heading attached to the printed document.   
f. Additional Print Settings/Features: 

• Select Options>Auto Print to print all messages  
• Select Tools > Unattended Printing to leave FORCE in but to disable the use of the Force 

application; this allows any unsolicited messages (AM, YQ, YR and Broadcast messages) destined 
for the Force application to be delivered to the default Windows printer associated to that Force 
Mnemonic in addition to the Omnixx Force Message Window.  

• From the message window, printing can be accomplished in several ways:  
o Click in the box(es) of the message(s) you want to print and then select File > Print from the 

Message window Menu Bar (or press CTRL-P).  
o Select Windows Printer, print to default to print to your Windows Default Printer.  
o Select the message and right mouse click. Options include:   

• “Send to Line Printer” prints to LPT1 if a printer is configured.  
• “Send to Graphic Printer” allows you to select a printer from a list.  
• “Print to Default” prints to your windows default printer 

 
 
 


