Getting Started

Welcome to Omnixx™ Force, the desktop application module of the Omnixx™ Suite of products from Datamaxx Applied Technologies, Inc. Omnixx Force works from within your agency’s network to provide browser-based functionality that meets the needs of today’s law enforcement community. It allows users to send and receive text-base messages over dedicated law enforcement networks. These messages can be of an administrative nature or contain data elements for insertion into local, state, and federal databases.

Accessing Omnixx

If this is the first time that Omnixx Force is being accessed on your machine or if you are unsure if the application has previously been accessed, please see your Systems Administrator or T.A.C.

Omnixx Force is a browser-based application, meaning that it is accessed through a web browser. To access OFB:

1. If a shortcut icon has been created, double-click the shortcut icon on your desktop. **Or,**

2. If no shortcut icon is available you will need to access Omnixx through a web browser. Double-click on the browser icon on your computer’s desktop. In most cases, the icon will be for either Internet Explorer or Netscape Navigator. The browser should direct you to the Omnixx Login Home Page that is shown below. If you are not taken to the Login page you must type the URL (web address) of the Omnixx server into the browser’s address bar.
Getting Started

A. **User ID and Password**: You are required to enter a User ID and Password. If you have not been assigned an ID and password, see your administrator.

B. **New Password and Confirm**: Enter a new password if you wish to change your current password and then re-enter it in the “Confirm” box.

C. **Click here for more Log In details**: Provides additional logon credentials. Details on this screen include:

- **User ID and Password**: Another place you can enter your username and password to login into Omnixx

- **Agency**: Your Agency’s identifier. *Should not be changed*
- **Validation Code**: Value that identifies your machine to the Omnixx Server. This may be an ORI, machine mnemonic, etc. *Should not be changed.*

- **Omnixx Path**: Drive letter and/or path to which the Omnixx directory is installed.

- **New Password and Confirm**: Another place to enter a new password if you wish to change your current password and then re-enter it in the “Confirm” box.

---

**D. Click here for Instructions to Setup Omnixx**: Application that must be installed on your machine in order to be able to run Omnixx. This only needs to be done on this machine one time before the application is accessed. Note: This link will not display if you accessed Omnixx through the shortcut icon on your desktop.

After all necessary information is entered correctly, click the Log In icon. The Omnixx Certifications window will open displaying your current certification status. If your agency provides testing and/or training through Omnixx you will be able to click on the Class Schedule tab to see for which classes you are registered. If this feature is unavailable to you, the Class Schedule screen will be blank.

Click **Print** to send the information displayed to the printer and click **Close** to exit the certifications window.

### The Omnixx Desktop

Once you have logged in and have closed out of the Omnixx Certifications screen, the Omnixx Desktop will display. From here you can access all the Omnixx
Getting Started

applications that you are authorized to use. This screen may contain up to three separate access icons, but the only one covered in this manual is the Omnixx Force access icon.

The Omnixx Desktop not only provides access to the Omnixx Suite of applications, but provides options under the Menu Bar that allow you to change your password, display your certifications, and view help information regarding the applications.

File Menu

The **File** menu provides resources to:

**Change Password:** Displays the following screen, allowing you to change your password after you have logged into Omnixx. Enter the password that you used to access Omnixx into the Current Password textbox, and your desired password into the New Password textbox. Confirm your new password by entering it again in the Confirm textbox. Click **OK** when you are done. Click **Cancel** to abort the process and leave your password unchanged.
You cannot change your password once an Omnixx Client application (e.g., Force, Trainer, or Console) has been executed. If you select the “Change Password” menu item after an Omnixx client application has been started, the following dialog will be displayed:

**Modify User Info**: Displays the following screen, allowing you to enter or modify the user information associated with your Omnixx account.
Exit: Closes the Omnixx Desktop, which logs you out of the system. The following confirmation box will display, allowing you the option to abort the exiting process and remain logged into the system.

Applications Menu

The Applications menu provides a drop-down list of the Omnixx applications the current user is allowed to access. These will be the same applications that appear as icons on the desktop.

Help Menu

The Help menu provides access to the following resources:

Certifications and Classes: Opens the Certifications screen that displays the current user's certifications and respective expiration dates.

Properties: The Omnixx Configuration Properties dialog box contains six (6) tabs:

- Agency
- Subagency
- User
- Device
- Applications
- Settings
Each tab displays read-only configurations settings. The configuration settings can be useful in trouble-shooting situations.

**About Omnixx Desktop**: The *About Omnixx Desktop* screen provides you with pertinent information about the version of Omnixx Desktop software currently running on your system. The *About Omnixx Desktop* screen is shown below and is followed by a description of each feature.

The information contained in the *About Omnixx Desktop* screen provides the user with the software version number for the Desktop, technical support contact information, and property settings for the Desktop software.
By clicking the **Support** button, you are provided with technical support contact information, usually in the form of a toll-free phone number. Click the **OK** button to close the information box and return to the *About Omnixx Desktop* screen.

The **Properties** button displays the Omnixx Configuration Properties dialog box as shown previously.

**License Agreement:** The **License Agreement** menu option displays the Omnixx Desktop Software License Agreement for the Omnixx Desktop application as a Microsoft Word document.

### Opening Omnixx Force

Locate the Omnixx Force application icon on the desktop and click it once.

When the Security screen displays, click **Yes** to continue.

At this time, Omnixx Force will synchronize with the Omnixx Repository to ensure that your computer has the most current version of all files available. If not, the
system will automatically update them for you. As this is taking place, the following status screen will be displayed:

Depending on configuration settings, you may be asked to apply application updates. Selecting **yes** will download and apply all new updates. This process may take a few minutes. By selecting **no** you are choosing to use Omnixx Force without applying any of the new updates.

Once synchronization with the Omnixx Repository is complete, the Omnixx Force user interface opens and you are ready to begin.
An alternate mode for accessing the Omnixx Desktop may be available if communications with the Omnixx web server cannot be established. If this feature is available to you, a shortcut icon will appear on your computer desktop. If a local login feature has not been created for you and you wish to have this feature enabled, see your Systems Administrator or contact Datamaxx Technical Support.

**Local Mode** is a safety feature that initiates an Omnixx session locally. Users must have logged into Omnixx Force through the web server at least once in order to log on locally. This method assumes that the network connection to the host switch (e.g., OpenFox, LEMS, etc) is still available. The Local Login screen is shown below.
To avoid the problem of knowing whether there is an active connection to the web server, it is best to log into Omnixx using the Local Login. If the connection to the web server has been lost, then the user will be logged in locally. If there is an active connection, then the user will connect through the web server.
Transaction Forms

Transaction forms provide the user a simple interface for accessing state and federal law enforcement databases. Certifications created and assigned at the administrative level will restrict or permit access to forms for each user. Depending on certification settings, users may not be able to see forms they are not authorized to use. Therefore, the list of forms in the Forms menu may appear different depending on the user.

Elements of Transaction Forms

All forms in Omnixx Force contain certain features that interlay with a basic form structure. The following subsections describe the basic features and structure of each form in the application.

Fields and Groups

Fields and groups define the physical layout of the form. A Field is a single location that is allocated for entering particular information. Most fields in Omnixx Force appear as text boxes, but can also be such things as radio buttons and check boxes.

A Group is a collection of related fields in an Omnixx Force transaction form. A form may comprise one or more groups.
List Boxes

List boxes are associated with all fields in any form that require an NCIC code value. The list box contains the values (codes) for a particular field. A small button with three dots designates the list box, which is located to the right of the field. List boxes will appear as a single level or bi-level pop-up menu.

The Vehicle Color list (VCO) above is a simple list of color codes. The Operator License State list (OLS) above illustrates a bi-level list. Bi-level lists are split into category and sub-category panes. Unlike the single level list, which requires only one selection, the bi-level list requires the user to make two selections.

To make a selection from a single level list:

1. Click the box with your mouse, or use the CTRL + DOWN ARROW key command.
2. Use the mouse to double-click on the desired entry, or
3. Use the up and down arrows on the keyboard to highlight the desired entry, then press the ENTER key to select it.

To make a selection from a bi-level list:
1. Click the box □ with your mouse, or use the CTRL + DOWN ARROW key command
2. In the upper pane, highlight the appropriate category and the list of possible codes for that category will be displayed in the bottom pane.
3. To change the focus from the top pane to the bottom pane press the TAB key twice or click in the bottom pane using the mouse.
4. Use the up and down arrow keys to move to the desired selection, or use the scroll bar on the right, then use the mouse to click on the desired selection. Either double-click on the desired code or press the ENTER key when the correct code is highlighted.

Field Validation
Fields are checked for valid data each time:

- The TAB button is pressed, and
- When the transaction form is transmitted

Pressing the TAB key to move the cursor out of a field triggers an edit check of that field. If the user uses the mouse to move out of a field, then the validation check will not be performed until the form is transmitted. The example below illustrates the error message that is displayed when invalid information has been entered into a name field.

![Field Validation Error Message]

Clicking the OK button will place the cursor back into the field with the invalid data. Clicking the Override button will move the cursor to the next field in the form, leaving the invalid data untouched. If a user overrides an edit check, the form may still be rejected by the state switch.

Right-Click Menu
Certain functions can be carried out in Omnixx Force by right clicking in any field within a transaction form to display the following pop-up menu.
Cut – Removes highlighted text from its current location and places it on a temporary “clipboard”. This is one way to remove text, however, because it has been placed on the “clipboard” it is not permanently deleted and can be placed somewhere else.

Copy – Duplicates highlighted text and places it on a temporary “clipboard”.

Paste – Places text that is on the temporary “clipboard” at the current cursor location.

Undo – Reverses the last action taken in data entry within a form.

Clear – Removes all highlighted text. Clear is another way of deleting text, however, this method does not place the deleted text on a temporary “clipboard”. Therefore, if clear is used to remove text from a field, it cannot be pasted elsewhere.

Clear Group – The Clear Group function gives the user the ability to quickly clear all fields in a group contained in a transaction form. Place the cursor in any field within the group, then click the clear group option on the right-click menu. Omnimx Force will delete all data previously entered into the fields in that group and place the cursor at the beginning of the first field in the group.

The example below shows a form with information contained in the “Agency/Case Data” group and the “Person Data” group. To clear the information in the “Person Data” group only, place your cursor into any of the fields within this group, and click the Clear Group menu item.
The following figure illustrates the same transaction form after the Clear Group function has been executed. Notice the fields in the “Person Data” group have been cleared, but the information contained within “Agency/Case Data” group remains.

Field Help – A feature of Omnixx Force that defines data contents for a specific field. The Field Help dialog box displays guidelines regarding what type of information should be entered into the field as well as the correct format for the data. Selecting Field Help from the right click menu will display a help screen similar to the one shown below.
Clicking **OK** will close the Field Help dialog box. Clicking **Print** will send the information contained in the dialog box to the printer.

**Mark for Deletion** – Used in Modify forms only, this feature inserts a “delete” token into field. After transmitting the form, this token notifies the host that the information contained in the field needs to be deleted from the record.

**Replace** – Opens a dialog box that allows the user to replace specific text with alternate text. This feature is best used in large text fields where multiple lines of text appear (e.g., in an Administrative Message as shown below).

**Insert Data String** – Opens a selection box that enables you to choose from a list of commonly used data values. Select the data string that you wish to insert into a
particular field and click **OK**. Click **Cancel** to abort the operation without inserting any data strings.

### Auto-Fill for VIN

By entering a valid Vehicle Identification Number (VIN) certain fields can be automatically populated based on information from the National Insurance Crime Bureau. When a valid number is entered into the VIN field a prompt will appear as shown below.

From the prompt, the user can click **OK** to populate the YVR and MAK fields or click **Cancel**, closing the dialog box without populating the fields. The check boxes can also be used to deselect either or both of the fields to be populated.

### Accessing Forms

Forms may be accessed four different ways:

- From the Forms Menu in the Menu Bar
- From the Tree Menu
- From the Command Bar
- Through the use of Quick Keys.
Using the Forms Menu

The Forms Menu comprises a list of categories and subsequent subcategories. Some categories can include multiple subcategories. To open a desired form:

1. Click the **Forms** menu on the menu bar

2. Select a transaction category from the list
   -- *A cascading menu will display a list of transactions for the category that you selected.*

3. Click on the desired transaction form

Using the Tree Menu

The Tree Menu is a list of folders and subfolders, each containing transaction forms. The Tree Menu layout is identical to that of the forms menu with each folder representing a category and each subfolder representing a subcategory. To open a desired form using the Tree menu:

1. Select a transaction category by selecting a folder in the menu tree at the left of the screen.

If Tree Menu is not displayed, select **View Tree Menu** under the Options Menu.
2. If necessary, expand any submenu folders by double-clicking the subfolder or single clicking the plus sign (+) to the left of the folder.

3. Once the form name is displayed in the Tree menu, double-clicking on the form name will open it.
Using the Command Bar

The Command Bar is located at the bottom of the User Interface screen and provides keyboard access to two commonly used features:

- Opening a transaction form and,
- Inserting data strings

To open a form using the Command Bar:

1. Move cursor to the Command Bar, either by using the mouse or by using the keyboard command CTRL + G.

2. Type the letters “TF” followed by a space and then the Message Key (MKE) of the desired transaction form, as shown in the example below.

   ![Command Bar Example]

If a valid message key is entered, Omnixx Force searches for and displays the correct transaction form. If an invalid Message Key is entered, the following error will be displayed and the user should repeat step 2 using a correct Message Key.

   ![Error Message]

Transmitting Forms

After all necessary information has been entered into a transaction form; it must be transmitted for processing by the host network. Omnixx Force allows several methods of transmission.

To transmit a transaction form, perform one of the following methods:

- Click the Transmit icon on the Toolbar

- Click on the Comm menu, and select Transmit

- Press CTRL + T on the keyboard
- Press the + key on the numeric keyboard
Message Window ............................................................................................ 23
Accessing the Message Window ........................................................................ 23
Message Window Components ........................................................................... 24
Menu Bar ............................................................................................................ 25
  File Menu ........................................................................................................ 25
  Edit Menu ....................................................................................................... 26
  Options Menu ................................................................................................ 26
Message Display Window ............................................................................. 27
Message Display Components .......................................................................... 28
Menu Bar ............................................................................................................ 29
  File Menu ........................................................................................................ 29
  Edit Menu ....................................................................................................... 30

Message Window and Display

The Omnixx Force Message Window contains all sent and received messages from
the current session. A session is considered to last from the time a user logs on
until the time the user logs off. Therefore, a user will begin with a blank Message
Window every time Omnixx Force is launched.

Accessing the Message Window

There are three ways to manually access the Message Window in Omnixx Force.

- From the Message Window icon on the Toolbar
- From the Tools menu, click Message Window.
- From the Message Counter on the Status Bar.

To configure the Message Window to automatically open upon receipt of new
messages select Options from the Main Menu --> Auto Switch to Message
Window.
**A. From and To** – Displays the date and time of the oldest message that was received in the Message Window and the date and time of the most recently received message. By default, the Message Window is sorted with the newest messages listed at the top of the window and the oldest messages at the bottom. Date and time are recorded for the current session; however, the date and time of the earliest received message will remain even if the user clears the message window.

**B. Selection Checkboxes** – Allow the user to print or delete more than one message at a time. In the Message Window, messages may be printed or deleted. Selecting a checkbox on a message indicates that the message will be printed or deleted.

**C. Message Icons** – Visual indicator of whether a message was sent or received and whether the message has been viewed.

- Indicates an *Unread* received message
- Indicates a *Read* received message
- Indicates an *Unread* received message that contains a *Hit*.
Indicates a Read received message that contains a Hit.

Indicates a Sent message

D. **Date/Time** The date and time that the respective message was sent from the workstation or the date and time that the message was received.

E. **Subject** – Short summary of the message contents

F. **Type** – Description of whether the message was sent or received.

G. **Image** – Indicates whether or not an image is embedded in the message.

H. **Ref ID** – A number assigned to a message. Each sent transaction is assigned a unique number, and when the response message comes back to the device it will be assigned the same number as the sent transaction.

I. **Preview Pane** – A configurable option, which when activated allows the user to view contents of a selected message without having to open the message.

**Menu Bar**

The Omnixx Force Message Window Menu Bar contains three elements:

- The **File Menu**
- The **Options Menu**
- The **Edit Menu**

Under each menu element are functions for managing messages in the window as well as functions that turn certain Message Window options on and off.

**File Menu**

The **File** menu contains the following five (5) functions: **Print**, **Print Message List**, **Print to Default**, **Text Preview**, and **Exit**. The first four options relate to printing and are explained in the **Message Options** chapter. Please see this chapter for an explanation of these menu items.
Exit

The **Exit** command **closes** the Message Window.

Edit Menu

Functions under the **Edit Menu** provide a way to quickly select multiple messages for printing or deleting.

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Deselect All</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Checked</td>
<td>Ctrl+K</td>
</tr>
</tbody>
</table>

**Delete**

- **All** – Removes all messages in the Message Window, except for any unread messages.
- **Checked** – Removes only those messages that have a check mark next to them in the Message Window.

**Select All** – Places check marks next to all messages in the Message Window. Works in conjunction with printing and deleting messages. All selected messages may be sent to a printer or deleted from the Message Window.

**Deselect All** – Removes all check marks next to messages in the Message Window.

Options Menu

The **Options Menu** has functions that activate/deactivate Message Window displays. Functions available under the **Options Menu** include:

- Message Preview Pane
- Display Sent Messages
- View Command Bar

Options:

- Message Preview Pane
- Display Sent Messages
- View Command Bar
Message Preview – When activated (checked), displays the message preview pane on the bottom of the Message Window.

Display Sent Messages – When activated (checked), all sent messages appear in the Message Window in addition to all received messages. No sent messages will display in the Message Window if this option is deactivated (unchecked).

View Command Bar – When activated (checked), displays the Command Bar in the Message Window.

Note: If a message is delivered to the Message Window and the user does not read the message for a predetermined period of time (normally six minutes), the message will automatically display in the Unread Message Timeout Alert window, as shown below. Click OK to proceed.

Message Display Window

To view an individual message, double-click the message with your mouse. The message will display in a new Message Display Window. The main Message Display components are displayed below.
Message Display Components

A. **Message Chronology** – This area contains the following information about the current message.

- The chronological number of the message in the Message Window.
- Message type: *Sent* or *Received*.
- Date and time that message was sent or received.
- The Operator, ORI, and device Mnemonic that is associated with the message.

B. **Toolbar** – The toolbar provides quick access buttons for printing message displays and navigating through messages in the Message Window.

- **Print** – Sends the current message to the printer. Does not open a print dialog box, enabling you to select a different printer.

- **First Message** – Displays the first message listed in the Message Window.

- **Previous Message** – Moves you *backward* through the Message Window displaying one message at a time.
**Next Message** – Moves you forward through the Message Window displaying one message at a time.

**Last Message** – Displays the last message in the Message Window.

C. **Message Display Window** – Area that contains the actual text of the message.

*Received messages* can be viewed as Formatted Input or Received Input. The Received input view is unformatted data as it was delivered from the switch.

*Sent messages* can be viewed as Formatted Output, Sent Output, or as User Inputs. Similar to Received Input, the Sent Output view displays the message as it was sent to the switch. The Formatted Output tab displays the “cleaned” version of the same message. The User Inputs tab displays a formatted view of the data entered into the transaction form that comprised the message. The Formatted Output tab is the default view.

**Menu Bar**

The **Menu Bar** of the Message Display window contains two elements: The **File** menu and the **Edit** menu.

**File Menu**

The **File** menu contains the following functions:

- See the printing section of the *Message Options* chapter for explanations of **Print** and **Print to Default**.

- The **Exit** function closes the Message Window.
Edit Menu

The Edit menu contains the following functions:

- **Copy** -- Duplicates highlighted text and places it on a temporary “clipboard”.

- **Go To** -- The functions **First**, **Last**, **Next**, and **Previous** allow you to navigate through the messages in the Message Window.
  
  - **First** -- Displays the first message listed in the Message Window.
  
  - **Last** -- Displays the last message in the Message Window.
  
  - **Next** -- Moves the user forward through the Message Window displaying one message at a time.
  
  - **Previous** -- Moves the user backward through the Message Window displaying one message at a time.

Tip: It is useful to use the navigation buttons to open multiple messages without leaving the Message Display Window. Without closing out of the Message Display window use the buttons to move up and down through your messages.
Message Log Window

The Omnixx Force Message Log allows you to search for and view messages that have been sent or received on a particular machine. The Message Log is permanent, searchable, and read-only.

Accessing the Message Log

There are three ways to access the Message Log in Omnixx Force:

- Click on the Message Log button on the Toolbar.

- Click the **Tools** menu on the Menu Bar, and then click **Message Log**.

- Click on the **Log** in the Status Bar.
Message Log Window

Message Log Components

A. Search Criteria – This area provides search criteria fields where a user enters information that is used to run a search of the Message Log. The user can make the search broad or narrow by entering as much or as little information as is available into the following fields:

- **ORI** – The ORI associated with the message you want to search for.
- **Term** – The terminal ID associated with the message you want to find.
- **SLog** – “Special Log” field that is used for dissemination logging. Special Logs provide a mechanism for grouping and tracking sent transactions in the Message Log. For example, if an administrator assigns the text “CCH” to IQ and QH transactions, then when a search is performed using the text “CCH” is the **SLog** field; the search results will show all sent transactions for the IQ and QH transactions.
- **Operator** – The operator ID associated with a message you want to find.
- **Start Date** – Searches for messages that were logged beginning with this date.
- **End Date** – Searches for messages that were logged up to this date.

The **SLog** field is a configurable option in the form design and is covered in Application Rules Editor. Note: This is an administrative application.

The **Operator ID** field can be configured to automatically populate the current user’s User ID in a “read-only” format, meaning it cannot be deleted or changed. This ensures that a user can only view their own messages.
- **Start Time** – Searches for messages that were logged beginning with this time.
- **End Time** – Searches for messages that were logged up to this time.
- **Search For** – Any specific text contained in a message that you are searching for.
- **MKE** – A message key related to a specific transaction form that you are searching for.
- **Type** – Message type. Allows you to narrow down the search to Sent, Received, or All messages (defaults to All messages).

B. **Message Display Area** – All messages that meet the criteria specified in the Search Criteria fields. The information displayed for each message duplicates the same information displayed in the Message Window.

C. **Command Buttons**
- **Search** – Displays the results of your search
- **Print** – Sends selected messages to the printer
- **Exit** – Closes the Message Log

D. **Optional Preview Window** – A configurable option, which if activated allows the user to view the contents of the message selected in the top pane (Section B).

**Menu Bar**

The Message Log menu bar contains four elements:

- **File menu**
- **Edit menu**
- **Tools menu**
- **Options menu**

**File Menu**

The **File** Menu in the Message Log parallels that of the File Menu in the Message Window. **Print, Print Message List, Print to Default, and Text Preview** are covered in the **Message Options** chapter in the section titled, “Printing”.
Exit

This function closes the Message Log.

Edit Menu

Functions under the Edit Menu provide a way to quickly select multiple messages for printing or deleting.

Select All – Places check marks next to all messages displayed in the Message Log. Messages in the Message Log are selected for printing. Once messages are selected, the print can be used to send all messages to the printer.

Deselect All – Removes all check marks next to messages in the Message Log.

Tools Menu

The Message Log comprises two different log types: Current Logs and Archived Logs. The Current Log contains all messages that have not been archived. The Tools menu provides a function for moving messages in the Current Log to an Archived Log. This function is necessary when the Current Log reaches its maximum capacity or when the user notices a significant increase in the time it takes to run a search.

The tools menu contains the archive function.
Archiving

To archive messages:

1. Select **Archive** from the Tools Menu.

![Archive Messages Window](image)

2. Enter the *From* and *To* dates to define which messages will be archived. Click on ![Button](image) next to the text boxes to display a date selection dialog box.

3. Click **Continue** to start the archiving process. To cancel out of the process without archiving, click **Exit**.

*The following message screen will be displayed upon completion of the archive.*

![User Info Window](image)

Each time messages are archived a file containing all messages between the specified date range is created. These files are listed under the **Logs** tab in the Message Log window.
From and To – Date range of messages contained in the file.

# of Messages – The number of messages contained in the file.

File Name – Unique identifier that is automatically generated by the application. The default naming convention uses the date range of the messages contained in the file, followed by a file number. The file number will always be 001 unless more than one archive is performed using the same date range. Then file numbers will increment as 002, 003, etc.

Searching Archive Logs

Once messages have been archived, they will no longer be searchable in the Current Log. To include a log that has been previously archived in your search:

1. Enter desired search criteria into the Search Criteria section of the Message Log window.

2. Click the Logs tab.

3. Select the Log(s) to be included in the search by clicking the corresponding checkbox(es), or click the Select All button to include all archived logs in the search.

4. Click the Criteria tab.
   Note: Make sure the dates have been removed from the date fields or change the dates to reflect those of the files you are searching.

5. Click Search.
Message Options

Omnixx Force provides certain functions for manipulating, displaying, and printing messages. These functions apply to all sent and received messages in both the Message Window and Message Log.

Printing

OFB includes two separate print methods: Line and Graphic. These may be installed as two separate printers or as two different types of connections to the same physical printer.

The Line Printer is a dedicated printer connection which does not utilize any "Windows" capabilities that may be available. Images and various type styles will not appear in the printed document.

The Graphic Printer makes full use of the Windows features available on the printer. In addition to supporting images and variable fonts, the Graphic definition is compatible with network printing and allows for the selection of alternate printers, where available, for each printing task.

The most direct way to print messages in the Message Window and the Message Log is to right-click on the message. This immediately provides three options for printing: Send to Line Printer, Send to Graphic Printer, and Print to Default.
- **Send to Line Printer** If a line printer is defined, this is the quickest print method but will not print images.

- **Graphic Printer** The Graphic Printer (if there is one on the network) is a good choice for quality output, especially where images are involved.

- **Print to Default** will either send the message to the line printer or the graphic printer and is dependent on another setting. This print option will be discussed later in this section.

If you right-click on the message in the Message Preview Pane, you get the same print options with a variation in other choices:

You can print multiple messages at once by clicking the box to the left of the messages and selecting the **File Menu**. [Be sure that you don’t choose the File Menu form the Forms Window which appears just above.] The **File Menu** is similar to the following (allowing for local customizations):

---

Datamaxx Group, Inc.
If you choose *Text Preview* from this menu, the messages that were selected in the Message Window will display in a separate preview window as shown below.

If you right-click in the *Text Preview* Window, you will see this menu:

- Cut
- Copy
- Paste
- Print Selection
- Print To Default

Alternatively, you could click the PRINT button at the bottom of the Text Preview screen and you will see the Windows print dialog box allowing you to select a printer from the network:
The four menus illustrated above all include a Print to Default option. But what is the default setting? To determine this, you need to access the dialog box used to set the default. This is not directly available through a menu choice but can be reached by selecting a print command which displays it.

The quickest way to do this from the Message Window is to select any message (by checking the box to the left of the message) and press CTRL + P (shortcut button to print). The following screen will display:

Default refers to which radio button is selected (Line Printer or Graphic Printer). In this illustration, the Line Printer is the default printer.

The Print to Default option is designed to facilitate a bypass of the Windows Print dialog. If the Graphic Print option is selected AND the Print to Default box is checked, the “Right-click Menu – Print to Default” in the Message Window, Message Display, Message Log, and Text Preview will send the message immediately to the workstation’s default Windows printer. Additionally, the print BUTTON in the Message Display performs similarly although there is no “default” indicator to suggest that it will.

Sent Messages – “Right-Click” Menu

All functions applying to sent messages are accessed from the right-click menu. The five ways you can manipulate and display sent messages are:

- Display Base Message
- Display in <original> format
- Send to Line Printer (See Printing)
- Send to Graphic Printer (See Printing)
- Print to Default (See Printing)
- Forward Message

**Display Base Message**

The **Display Base Message** option in the right-click menu will open the selected message in its Message Display window. To open a sent message from either the Message Window or the Message Log Window:

1. Right-click on the desired message and click **Display Base Message**.

The message will open in the Message Display Window. All information contained in the window appears exactly as the user entered it.

**Display in XX Format**

This function allows you to select a *sent* message and repopulate the information into the transaction form in which it was originally entered.

*Note:* XX represents the Message Key of the transaction form that was originally transmitted.

To display a message in its original format:
1. From either the Message Window or the Message Log Window, right-click on the desired sent message and click on **Display in XX Format**.

The information contained in the message is repopulated into its original transaction form and the form opens automatically in the user interface screen. Changes can be made to any information contained in the form and then the form can be resent.

**Forwarding Messages**

In Omniux Force, it is possible to forward a previously sent message. This option is available from the Message Window or the Message Log. The information from the message is automatically entered into an Administrative Message for transmission.

To Forward a *Sent* message:

1. From the Message Window or Message Log, right-click your mouse on the selected *Sent* message and click **Forward Message**.
An Administrative Message form populated with the information contained in the *Sent* message will open.

2. Enter a Destination Code and click the transmit button on the toolbar.

**Received Messages – “Right-Click” Menu**

The Message Window and the Message Log Window contain a menu that allows users to forward received messages, send a message to a line or graphic printer, and keep or unkeep specific messages.

**Forward Message**

The same method used to send *Sent* messages to other users also applies to *Received* messages. To send a *Received* message to another user, right-click on the message and select **Forward Message** from the menu.
Keep Message

The Keep Message option may be used to maintain a message in the Message window across sessions. Messages chosen to be “kept” will remain in the message window across all user logins until “unkept”. For example: If a message is kept by a user, the next user who logs onto the machine will see this message in his/her Message Window. The Keep option is available in both the Message Window and Message Log, and a message that no longer appears in the Message Window may be retrieved from the Message Log and put back in the Message Window as a kept message.

Selecting the Keep option will change the icon of the message to a closed envelope containing a flashing ‘+’.

Unkeep Message

The Unkeep Message option is used to remove kept messages from the Message Window. A kept message cannot be deleted or removed from the Message Window until it is “unkept”. You will receive the following error message if you attempt to delete a kept message:

It is not necessary for the user who kept the message to unkeep it. Any user may unkeep any message.

Confirming “Hit” Messages

When a hit is received from NCIC, the following alert will appear on the screen:

The message containing the “hit” will also be identified by a blinking red exclamation mark. The exclamation mark will remain even after the message has been read.
To send an automated Hit Confirmation Request based on the received information:

1. Right-click on the message containing the hit.

2. Select the desired YQ transaction.

The YQ form will open with the hit information pre-filled as shown below.

3. Since pertinent data is automatically pulled from the hit message, it may only be necessary to enter the remaining mandatory fields for transmission: Hit
Confirmation Request Number (RNO), Priority (PRI), Requestor Name (RNA), and Requestor Agency (RAG).

4. Click **Transmit** to submit the Hit Confirmation Request.

In addition to confirming Hits, you will have the option to open and populate *Hit Confirmation Responses* and *Locate forms*. For example, right-clicking on a Hit Confirmation Request will give you the option to open a Hit Confirmation Response form. Right-clicking on a Hit Confirmation Response will give you the option to open a Locate form.
Quick Keys and Macros

Quick Keys provide a mechanism for users to assign keyboard shortcut values to open Forms, execute Macros, and insert Data Strings. The keyboard shortcuts assigned to perform these actions are referred to as “Quick Keys”. Quick Keys are created and maintained using the Omnixx Force Quick Key Wizard.

Creating Quick Keys

To create a new Quick Key:

1. Click on the Tools menu and select Display QuickKey Wizard.

2. Make sure the Create a new QuickKey radio button is selected.

3. Click Next.
4. Enter a name for the QuickKey and select the radio button of the action it will perform.

5. Click **Next**.

6. Select the appropriate form, macro, or data string from the displayed list.

7. Click **Next**.
8. Select the Function Key or Combo Key radio button and then choose an available Key or combination key that will be used to initiate the selected action.

Note: *QuickKeys that have already been assigned will display in the window below Current QuickKeys.*

The following user information box will display if you attempt to create a QuickKey using a previously assigned key.

9. Click **Finish** when done.

**Macros**

**Macros** provide an alternative method for entering data into a transaction form, and are typically used to provide a shortcut entry format for frequently used transactions. Macro data is entered into the Command Bar and is executed by using an associated QuickKey function.
Creating Macros

To create a Macro:

1. Click on the Tools menu and select Display Macro Wizard.

2. Make sure the Create a new macro radio button is selected.

3. Click Next.

4. Enter a name for the Macro
5. Select a delimiter type for the Macro command. A delimiter defines what will separate each field in your macro command (e.g., ORI; NAM; DOB).

6. Select whether or not to clear the Command Bar after the Macro has been executed.

7. Click Next.

8. Select the Form that the Macro will be created for.

9. Click Next.
A list of available fields from the Form selected in Step 9 is displayed.

10. Highlight the first field to be included in the Macro. *Hold down the Control key on your keyboard to highlight more than one field at a time.*

11. Click the right (top) **Selection Arrow** to move the field to the list box on the right side of the screen; indicating it is part of the new Macro. Repeat this step until all fields that are to be included in the macro are in the list box on the right side of the screen.

12. Use the **Position Arrows** to manipulate the field order of the Macro. Once the fields are arranged in the order the user will enter them (top field is entered first), click **Finish**.

Once a Macro is created, you must assign it to a QuickKey in order to execute the Macro from the Command Bar.

**Executing Macros**

A QuickKey must be assigned to macros in order to run them as transactions. To assign a QuickKey value to your macro, follow the steps in the *Creating QuickKeys* section of this chapter. *In step 4 be sure to select the radio button Execute a Macro.*

Once a QuickKey has been assigned to a macro, perform the following steps to run a transaction:

1. Place your cursor in the Command Bar located at the bottom of the User Interface screen.
2. Enter data for each Message Field Code (MFC) for the macro, followed by the respective delimiter that was used in the creation of the macro using the Macro Wizard. For example:

```
Command: NCDC0018.abc123.fil
```

3. Press the QuickKey assignment for the respective macro.

If a preloaded field (fields on a form that are populated with data when the form opens, i.e., ORI) is included in a Macro definition, then you do not need to enter the information into the Command Bar. The preloaded information will automatically be incorporated when the macro is executed. If a value is entered for a preloaded field in the Command Bar, this value will override the preloaded value.
THIS PAGE INTENTIONALLY LEFT BLANK
Images

Receiving Images

When a message is received into the Message Window that contains an image, the Image indicator for that particular message will display a “Y” to notify the user.
To view the image, simply double-click on the message and the Message Display window will open. The image will be displayed as shown below:

**Entering Images**

Depending on the transaction forms available there are various transaction options for entering an image or forwarding an image to another workstation. The following example will illustrate how to enter a photograph of a stolen vehicle to NCIC.

To enter an image:

1. Open the desired transaction form from the **Forms** menu.
2. Enter the ORI, NCIC Number, Date of Image, and Image Type.

3. Click on the button to the right of the Image field to open the following dialog box.
4. Click the **Load File** button to open the browser box to search for the image file on your computer’s hard drive.

5. Highlight the desired file, then click the **Open** button to insert the file.

6. The Image Loading dialog box will then display the selected image in the upper left-hand corner.

- **A. Load File** – Opens a browser to allow the user to search for the file to be transmitted.

- **B. Crop Image** – Allows the user to crop the image if it is too large to be transmitted.
C. **Image Ready** – After the image has been loaded and adjusted, click this button to complete the image loading process.

D. **Image Type** – Select the type of image being transmitted from this drop-down selection box.

E. **Contrast, Brightness, Zoom** – Use Contrast and Brightness to adjust the clarity of the image. Use the Zoom scale to zoom in or out as required. If the picture is larger than the allowed space, scroll bars will appear to the right and below the picture for further adjustment.

F. **Cancel** – Terminates loading of the image.

7. Once the image has been loaded, make any desired adjustments to the settings described above.

8. Click the **Image Ready** button to proceed.

9. If the selected image is too large for transmission the following error message is displayed:

10. Click the **OK** button to close the error message and use the **Zoom** feature to reduce the size of the image.

11. Once the image has been scaled down to an acceptable size (less than 31,000 bytes), click the **Image Ready** button again to proceed.

12. The image is now loaded into the EIM transaction form and ready for transmission.
Menus and Tools

There are three main elements of the Omnixx Force interface:

- Menu Bar
- Toolbar
- Status Bar

This chapter will describe all three elements and their functions in detail.

Menu Bar Options

The Omnixx Force Menu Bar, located below the Title Bar, consists of nine menu items. Each menu contains a drop-down list of commands relating to the respective menu item.

### File Menu

- **Save Workspace** – This option allows you to save the display of the user interface screen. By selecting **File – Save workspace** you manually create a “snapshot” of your user interface screen that is saved and can be reopened.

**Save Workspace** is convenient if you have forms you routinely use. This feature saves having to open all forms each time you log on.
each time you log into Omnixx Force. In addition, Omnixx Force will automatically save the workspace every time you log out of the application. The file name generated for this workspace will be your Omnixx user ID. This is a separate file from all other manually saved files and will be overwritten each time you log out of Omnixx Force.

- **Open Workspace** – Opens a dialog box for accessing previously saved workspaces. Using the dialog box, you can open a workspace that you have previously saved.

- **Print Setup** – Opens the prints dialog box, which allows you to enter the location of the printer to which Omnixx Force messages will be printed. If your printer has not been setup, see your Systems Administrator, T.A.C., or call Datamaxx Technical Support.

  **Note:** If print setup has not been established, this box will pop-up each time you attempt to use Auto Print or Unattended Printing.

- **Exit** – Closes the Omnixx Force User Interface.
Menus and Tools

Forms Menu

A cascading list of all forms is displayed in this menu. The forms available in this list will differ, depending on certifications held by the current user.

Edit Menu

**Cut** – Removes highlighted text from its current location and places it on a temporary “clipboard”. This is one way to remove text, however, because it has been placed on the “clipboard” it is not permanently deleted and can be placed somewhere else.

**Copy** -- Duplicates highlighted text and places it on a temporary “clipboard”.

**Paste** -- Places text that is on the temporary “clipboard” at the current cursor location.

Comm Menu

**Transmit** – This function sends the current transaction to the host for processing.
Options menu

Auto Switch to Message Window – When enabled, the Message Window will automatically open whenever a message is received.

Auto Print – When enabled, all incoming messages are printed without any necessary action from the user.

Spell Check Options – Allows users to set spelling preferences when Spell Check is performed in a form. This screen can also be accessed within the Spell Check dialog box.

View Command Bar – Toggles off and on the Command Bar at the bottom of the screen allowing data character input queries.
**View Tree Menu** – Toggles off and on the Tree Menu that is located on the left side of the screen.

- Master Query
- Administrative Messages
- Registration Queries
- Driver License Queries
- Criminal Histories
- NTIC
  - Index Record Existence (OH)
  - Criminal History Record (QR)
  - FBI/NCIC Index (QR)
- Nlets/SO
- DCT Index Messages
- HR Confirmations
- Articles
- Books

**View Banner** – Toggles the Banner Bar off and on near the bottom of the screen. Administrative messages, alerts, and other messages scroll across the Banner Bar, similar to a ticker tape message.

**Write Trace File** – When activated, this option traces your actions and generates a file that can be used to diagnose system problems. Clicking the **Trace File** Indicator on the status bar can also activate this option. *You should only activate a Trace File if requested to do so by Datamaxx Technical Support.*

**Check for Form Updates** – When activated, Omnixx Force will automatically query the repository every time a form is opened to check for any updates that may have been made to that particular transaction form. *This slows down form access considerably.*

**Tools Menu**

**Synch Rules with Repository** – Deletes the entire Omnixx DMML sub-directory from the local computer and downloads all files from the repository to ensure that all files are current. When activated, the following dialog box is displayed:

*Synching Rules with Repository may take considerable time and it is recommended that this action be performed under the instruction of a Datamaxx technical support professional.*
Click continue to follow through with the synch or click cancel to abort the operation.

**Message Window** – Opens the Omnixx Force Message Window, where messages from your current session are displayed. See Chapter Three for more detailed information on the Message Window.

**Message Log** – Opens the Message Log Window, which allows you to search and view messages that have been sent and received on your computer. The Message Log is described in greater detail in Chapter Four.

**Unattended Printing** – When activated, Unattended Printing acts as an alternative mode for Omnixx Force that allows a device to receive and print network messages without requiring a user to stay logged on to the system. Application functionality is limited to receiving, viewing, logging, and printing messages received from the host. When the **Unattended Printing** option is selected, a confirmation box similar to the one below is displayed.

Click **Yes** to continue logging off the current user and switch to Unattended Printing mode. Click **No** to abort the process and leave the current user logged on. If **No** is selected, the current user will stay logged on to the Omnixx Force application. If **Yes** is selected, the current user will be logged off and the system will revert to Unattended Printing mode. A confirmation similar to the following will be displayed:
Click the **Continue** button to complete the process.

**Check Update for Rules** – Checks the Omnixx repository for any changes that may have been made since the time you have logged into the application. If changes were made they will be downloaded when this option is selected.

**Perform Spell Check** – Opens the Spell Check dialog box as shown below. Spell Check is only available within transaction forms.
Display Macro Wizard – Activates the Macro Wizard, which is used to create and maintain macros. Macros provide an alternative method for submitting transactions without using a transaction form. Typically, macros provide a shortcut entry format for frequently used transactions. See Macros and Quick Keys chapter for more detailed information on the Macro Wizard.

Display Quick Key Wizard – Activates the Quick Key Wizard, which provides a mechanism for users to assign keyboard shortcuts to open forms, execute Macros, and insert Data strings. The Macros and Quick Keys chapter contains more detailed information on the Quick Key Wizard.

Windows Menu

The Windows Menu provides options for displaying open transaction forms.

Cascade – Diagonally aligns all open transaction forms, one in front of the other, with the title bars showing. The top window is active, while the underlying windows are inactive. To bring an inactive window to the foreground, click on its title bar.
Tile Vertically – Aligns all open transaction forms one on top of the other. This allows for simultaneous viewing of all open forms.
**Tile Horizontally** – Aligns all open transaction forms side-by-side, allowing for simultaneous viewing of all open forms.

**Close** – Closes the active transaction form.

**Close All** – Closes all open transaction forms in the Omnixx Force interface, but does not exit the program.

**Forms** – Opens a dialog box that contains a list of all open transaction forms. To direct focus to a particular form, select the form name and click **OK**.
Menus and Tools

Links Menu

Displays a list of links to helpful websites that are specific to your state/agency.

Help Menu

Documents – Opens the Documents submenu that includes links to the following items:


Omnixx License Agreement -- Displays the Omnixx Desktop Software License Agreement for the Omnixx Desktop application as a Microsoft Word document.

About Omnixx Force -- The About Omnixx Force Help screen provides the user with pertinent information about the version of Omnixx Force software currently running on the system. The About Omnixx Force screen is shown below and is followed by a description of each feature.
A. **Support** -- Click here for the Datamaxx Technical Support contact number.

B. **Properties** – Opens the Omnixx Configuration Properties window that provides configuration information for the local client. All information contained in the Omnixx Configuration Properties window is read-only.

![](image)

**Information displayed in Omnixx Configuration Properties window** contains specific information about the user and workstation. Some configuration information may be important when trouble-shooting with Datamaxx Technical Support.

C. **OK** – Closes the About Omnixx Force window and returns you to the Omnixx Force User Interface.

D. **Version** – Version number of the Omnixx Force application.

**Note:** You will be required to provide this number if trouble-shooting with Datamaxx Technical Support.
Menus and Tools

Toolbar Functions

The Omnixx Force Toolbar is located directly below the Menu Bar and displays toolbar buttons for the most commonly used commands. The Toolbar buttons and the commands they activate are described below.

Cut Button
Removes highlighted text from its current location and places it on a temporary “clipboard”.

Copy Button
Duplicates highlighted text and places it on a temporary “clipboard”.

Paste Button
Places text that is on the temporary “clipboard” at the current cursor location.

Print Button
Performs a screen shot of the currently active transaction form and any data contained within it. This Button will **not** work if a graphic printer is not configured.

Transmit Button
Sends a completed transaction form to the State Host for processing.

Message Window Button
Opens the Message Window.

Message Log Button
Opens the Message Log Window.

The Status Bar

Located at the bottom of the User Interface screen, the Status Bar provides information regarding the current status of your machine.
A. **Switch Indicator** – Displays the switch name to which Omnixx Force is connected. A green icon indicates a successful connection; a red icon indicates that the connection has been lost or was unsuccessful.

If connection to the switch is lost, it is possible to use this feature to attempt to reconnect or connect to another switch. This can be accomplished by performing the following steps:

1. Double-click the **Switch Indicator** icon. A **Switch Address** dialog box will open.

2. Leave the default IP or enter a different one if necessary. Click the **OK** button to continue.

3. In the **Switch Port** dialog box, enter a new port number or leave the default port address and click **OK**.

If the attempt to reconnect was successful, the switch indicator icon will turn green, indicating communication has resumed.

B. **Trace File Indicator** – Becomes framed in blue when the Write Trace File is being generated. You can turn the Write Trace File off and on by clicking on the indicator. 

C. **Validation Code** – Mnemonic or device name of the machine.

D. **User Name** – User name credential of the current user logged into Omnixx Force.

E. **Log** – Click on this to open the Message Log Window.
F. **Message Counter** – Displays the number of unread messages in the Message Window. Clicking on this box will open the Message Window.

G. **Time** – Displays the current system time.